Jump to content
Vagumera

Why am I constantly getting "Rejected - Invalid share"

Recommended Posts

are you using AMD gpu or NVIDIA

 

if using NVIDIA i recommend

https://github.com/tpruvot/ccminer/releases/tag/2.2.3-tpruvot

use the .bat

ccminer-x64 -a tribus -i 20 --plimit=85 --max-temp=75 --cpu-affinity=0x0 --cpu-priority=4 -o stratum+tcp://yiimp.eu:8533 -u DJs4qEg6Bbnpz7Md5k7FryshtfMPE8cw4H -p c=DNR

 

 

let me know if you need more assistance let me know.  If AMD i can research some more to find a good program and write a .bat. I also have a bash script or cooldown periods while overclocking. 

if i have been helpful and you feel  like tipping, my DNR address is:

DErbLLCntjn93tsykvwa2XhA4rFK52cBSR

Edited by krewshul
  • Like 1

Share this post


Link to post
Share on other sites
7 minutes ago, Vagumera said:

I'm using AMD gpu.

I tried the -a tribus but it still didn't work. I got the error that -a was an unknown parameter.

Some versions may use -k (kernel) instead of -a (algorithm) so try adding "-k tribus" instead. You need to specify which algorithm to mine on, in this case Tribus.


Founder of BlockForums.org - PM me for any help - Join our Discord Server: https://discord.gg/UPpQy3n

Share this post


Link to post
Share on other sites

Ok, got this working. 

I've got the following in my bat file.


sgminer.exe -c sgminer-dnr.conf 

 

and in my config file the following:

{
  "pools": [
    {
      "name":"hashbag",
      "priority": "0",
      "url": "stratum+tcp://hashbag.cc:8688",
      "user": "DJs4qEg6Bbnpz7Md5k7FryshtfMPE8cw4H",
      "pass": "d=0.25,stats",
      "profile": "tribus"
    }
  ],
  "profiles": [
    {
      "name": "tribus",
      "algorithm": "tribus",
      "shaders": "1792",
      "lookup-gap" : "4",
      "intensity": "19"
    }
  ],
  "kernel-path": "kernel",
  "default-profile": "tribus",
  "failover-only": true,
  "failover-switch-delay": "60",
  "gpu-dyninterval": "11",
  "queue": "2",
  "quiet": false,
  "expiry": "90",
  "scan-time": "20"
}

 

Now getting the below result:

image.png.2123c40f3420b820d96922c7d35dff13.png

image.png

  • Upvote 1

Share this post


Link to post
Share on other sites

I'd like to get my rig's temperature down to around 70 degrees.  It goes to around 80 degrees.

I've been trying the 

eg, sgminer.exe -c sgminer-dnr.conf --temp-target 69 --temp-overheat 75

 

but those options don't seem to make any difference.

Any ideas how to keep the temperature just below 70 degrees?

Thanks

  • Like 1

Share this post


Link to post
Share on other sites

Ok, I've done more experimenting and have come up with the following options

sgminer.exe -c sgminer-dnr.conf --temp-target 65 --temp-overheat 70 --auto-gpu --temp-cutoff 75

I've set intensity to 14 in my config file.

 

The rig can do much more than this, but I want to be able to leave the rig mining during the day without it consuming too much power or heating up too much.

Better to have a rig that I can just leave running, than having the fan hit 100% and all the noise.

I'll try out an even lower setting for nighttime mining, just so it ticks over.

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Sorry, should have realized it was AMD with you using SGminer. glad you got it working... if wanting to overclock and give rest periods this little bat file will help. just insert your bat file and the number of seconds you want to rest and run. sve as a .bt file and put in same folder as your miner. the only thing is it will leave a command window up every time it restarts. it wont be mining.. but it will be there. may have to "x" out of a couple when you check it. havent figured out how to get that one to close yet.... :) maybe you can

@echo off
echo xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
echo  Guess I will get up and start mining
echo xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
echo:
set miner=PUT YOUR .BAT FILE HERE
set run=PUT # OF SECONDS TO RUN HERE
set rest=PUT # OF SECONDS TO REST HERE
set /a counter=0
:start
start "miner window" %miner%
echo:
echo I will only do this for  %run% seconds. Then it's my naptime
timeout %run%
taskkill /t /f /im sgminer.exe
echo:
echo Be quiet, you dick!
echo I still have %rest% seconds left. I am in a union, you know? (%counter%)
timeout %rest%
set /a counter+=1
echo:
echo:
goto start

 

Edited by krewshul

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...