Jump to content

How to mine Monero and compile XMRig on a Raspberry Pi 4! CPU Mining in 2021!


Recommended Posts

sudo apt-get install git build-essential cmake libuv1-dev libssl-dev libhwloc-dev 

git clone https://github.com/xmrig/xmrig.git 

mkdir xmrig/build && cd xmrig/build 

cmake .. 

make -j4

Very simple, basically SSH into your Raspberry Pi 3 or 4 and run those commands above to download and compile the XMRig miner to mine Monero on your Pi.

To run the Monero miner, simply run:

./xmrig -o us-west.minexmr.com:443 -u 43ruPy2uKauGyB5vjxwg3LYjikfpNC9kPgyUKZbL9pAraW3e2GLQWWqY1bmBgzJHtsYsmcrYgSJV4eAooe8LvZ3ZEwXJKht -k --tls --rig-id pi4tut


Founder of BlockForums.org - PM me for any help - Join our Discord Server: https://discord.gg/UPpQy3n


Link to comment
Share on other sites

  • 1 year later...

Hi. I tried this just this morning and in the very first step "sudo apt-get install git build-essential cmake libuv1-dev libssl-dev libhwloc-dev" I get an error that the Pi is unable to locate package libss1-dev.

I tried continuing with the other steps, but it seemed to break down after that with additional errors. 

Any help would be apprciated.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...